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OVERVIEW 

  

What is Shape? 

Shape is a morpho-kinematic modeling tool for astrophysical nebulae. The main application of 
Shape will be the direct comparison of a 3D model with data in order to assist in the interpretation 
of observations. Starting from a 3D model of points with velocities, it generates an  image and 
position-velocity (pv-) diagram, channel map and one dimensional  spectral line shapes based on 
the Doppler effect.  

  

What can Shape do for you? 

The design purpose of Shape is the analysis of the 3D structure and kinematics of spatially 
resolved astrophysical nebulae in a way that can be compared directly with observations of 
similar real objects. It is particularly suited to study expanding nebulae like planetary nebulae and 
other structures with clear kinematical signatures like bow-shocks or accretion disks and other 
streaming flows that can be studied using the Doppler-Effect. 

The analysis may be applied for the interpretation of existing observations or the planning and 
prediction of observations based on a proposed model. 

Another potential application is the modeling of complex 3D structures as initial conditions of 
numerical photo-ionization and hydrodynamic calculations as well as the visualization and 
calculation of spectral information resulting from such calculations. 

The application of Shape as a teaching and learning tool for the interpretation of observations 
involving images, position-velocity diagrams, channel maps and spectral line profiles may help 
students and researchers alike become acquainted quickly with this type of data. 

What does Shape not do? 

Shape does not calculate the numerical hydrodynamic evolution nor radiation transfer for photo-
ionization models. Shape does not take a set of observational data as input to automatically yield 
a three-dimensional model.  

Non-astrophysical uses 

Shape may be applied to the analysis and visualization of data and models of objects observed 
with Doppler radars, such as tornados and other weather phenomena. Ocean surface 
observations with Doppler radar can also be modeled with some 3D animation packages. The 
application to the analysis of other types of Doppler data may, of course, be also possible. 

Have you got news for us? User publications and utilities page 

A webpage for Shape displayed at startup in the main interface of the software is a direct window 
that takes you right to the latest info on applications of Shape in the scientific literature. The page 
provides access to important up-to-date information on the software as well as model templates 
and model data from real applications that have been supplied by their authors. You are welcome 
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to make comments and suggestions for future releases of Shape and to share your own results 
with other users. Of course, as soon as a significant number of users is established, a discussion 
group will allow quick exchange of questions and answers to news and problems with model 
building in Shape. 
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IMPORTANT GENERAL INFORMATION  

TO TAKE INTO ACCOUNT BEFORE USING SHAPE 

Citations: 

In publications that include models that have been prepared with Shape, credit should be given 
citing the following original publication:  Steffen, W., López, J.A., 2006, Morpho-kinematic 
modeling of gaseous nebulae with SHAPE, RevMexAA 42, 99-105.  

Disclaimer 

This software is provided "as is". No warranty is given for its fitness for a particular purpose. 
Neither the authors nor their employers can be held responsible in any way for incorrect scientific 
or other results that may follow from the usage and interpretation of models produced with Shape. 

General modeling strategy 

Given a set of one or more spectral line images and position-velocity diagrams or channel maps, 
a first interpretation of the data should give an approximate "educated guess" of the 3D structure 
and kinematics of the object. This structure is then reproduced in a suitable 3D modeling program 
like Blender, 3DStudioMax, Maya, or the built-in 3D module of Shape. You export the vertices or 
particles of the structure built in an external program, including their velocities, in a format that is 
readable to Shape (see below for how that may be done).  From these data Shape then renders 
images, pv-diagrams and channel maps for different observational settings like object orientation, 
slit positions and slit widths, as well as different spatial and velocity resolutions.  

The parameters settings for the model and observing setup may be varied automatically to 
produce a series of different image sets that you can view in an animated form. Viewing 
animations of image sequences often aids at understanding the effect of the 3D structure and 
orientation on the spectral information. If the model does not reproduce the observations 
satisfactorily in any orientation or with any other adjustment that can be made in the main 
interface, you go back and refine your model taking into account the differences between model 
and observation. Iteratively you will improve your model until you are satisfied. The process may 
also reach a limit when you hit the limits of your modeling software or when the assumption made 
in the models and their rendering do not apply to the real object (for instance optical thickness). 

After arriving at a satisfactory model solution, the result may be inspected in various ways and 
scientific conclusions regarding the object structure, kinematics and orientation may be drawn. 

In most cases observational data of an astrophysical nebula are not sufficient to derive a unique 
solution for its 3D structure and kinematics. However, in many such cases, modeling with Shape 
can still help to gain new insight into the structure of the object. Objects that have relatively 
simple topology or some noticeable symmetry can usually be solved uniquely. It is 
recommendable to exploit any hint to symmetries or surface continuities, both, in the images as 
well as the spectral information even if such properties can be found only in local feature of a 
complex object. 
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Knowledge required prior to using Shape 

In order to profitably use Shape you should have at least basic knowledge about astronomical 
observing techniques like imaging, spectral line profiles, position-velocity diagrams and/or 
channel maps. The meaning of seeing and spectral resolution should be known.  

Although desirable, for simple modeling using the 3D module of Shape no previous knowledge 
about 3D modeling is required, since it can be based on the templates available from the 
repository on the Shape website. For complex modeling of objects that can not be obtained by 
simple modifications of the templates, you can produce your model using a 3D software that is 
capable of exporting your model in the VRML (Virtual Reality Markup Language) format, some 
other format that is available or in the native format of Shape via a script of the modeling 
software. Shape provides data export scripts for some 3D modeling suites (see below for 
details).  Check the ShapeSite (http://www.astrosen.unam.mx/shape) for currently available 

 

Software installation 

See the download section of the ShapeSite for details. 

 

The rendering engine of Shape 

The rendering of images and spectral information is an integrated projection of emission from 
individual particles (or polygon vertices which are treated as particles) onto the image or spectral 
plane. Color and brightness of the particles are controlled via a special color editor module. The 
individual particles are treated as circular planes which always face the camera with adjustable 
size and internal emissivity distribution. 

Limitations 

In Version 1.0 of Shape the integration along the line of sight is assumed to be optically thin. 
Capability to model optically thick nebulae will be included in Version 2.   

Considerations on image resolution in particle based models 

In order to obtain models with a complex structure, the number of particles that samples these 
structures has to be sufficiently high. The size of the convolution with the gaussian point-spread 
function should be sampled with at least a few particles. Note that structures that might not be 
resolved in the image, might well be resolved in the spectral information, such that a similar 
criterion has to be applied to structures that have details in velocity space that are "larger" than 
the velocity resolution. 
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USER INTERFACE 

The user interface has two main modules: the Main Control Interface (MCI) and the 3D module.  

When you run Shape, the Main Control Interface opens. Initially the MCI shows the menu bar and 
a row of tool buttons (Button Toolbar) the large News Panel, which gives access to up-to-date 
information on Shape. The MCI can be resized to suit your working area on the computer monitor 
maintaining access to the complete interface using the scroll bar on the right.  

In order to start using Shape for 
modeling and visualization you 
open a project or create a new 
one using the File rollout on the 
menu bar at the top. Now the 
News Panel disappears to make 
way for the image displays and 
the parameter control tabs. The 
top displays show the raw 
image (left) and the raw pv-
diagram or channel map (right). 
Similarly, the lower displays 
show image information on the 
left hand side and spectral 
information on the right. In the 
bottom displays the images 
have been convolved with 
gaussian point-spread functions 
like seeing and velocity 
resolution.  

The middle section contains the 
control parameters for the 
rendering of the images and 
spectral information (see below 
for details). This section 
includes parameters for the 
space that is covered by the 
image, the velocity range that is 
covered by the spectral 
information, as well as controls 
for the automatic rendering of 
sequences with varying 
parameters.  
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The news panel 

Is your window to the ShapeSite, the 
web site with news and up-to-date 
information about Shape, including 
models, templates, tutorial and news 
about applications of the user 
community of Shape. The News 
Panel is displayed when you start a 
session with Shape. Once you start 
working on a project, the News Panel 
disappears. You can toggle between 
the Project Panel and the News 
Panel any time by pressing the News 
Panel Button on the tool bar at the 
top of the Main Control Interface (see 
below). 

The News Panel at this stage is a 
limited Browser. You can only 
browse forward. To get back to the 
home page, press the Refresh 
button. At this time you can not 
download files using this page. To 
download templates and movies use 
the Internet Browser installed on your 
system pointed at the following 
Internet address: 

http://www.astrosen.unam.mx/shape 

Use the News Panel  to learn about 
updates and news as well as to read 
the User Manual. 
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THE MAIN CONTROL INTERFACE (MCI) 

WORKING WITH PROJECTS, DATA AND PARAMETER FILES 

       Menu Bar 

Opening an existing project: 

To open a recently used project open the Open Recent Project selector in the File rollout and 
choose one of the four most recent projects that you have worked on. The most recent is at the 
bottom of the list. 

Menu Bar > File > Open Recent Project 

To access other existing projects use the Open Project Dialog in File rollout of the Menu Bar. 

Menu Bar > File > Open Project  

Creating a new project: 

In order to create a new project with and existing Particle System data set open the Create New 
Project Dialog opening the File rollout in the Menu Bar : 

Menu Bar > File > New Project 

The Create New Project Dialog opens. In the first text field you enter a Project Name. In the 
bottom text field you enter the Project Directory path, which will be your Working Directory. 
The full directory path is either entered through keyboard input or by selecting the directory with 
the Browse to the right of the Directory text field. All the data that are created for this project are 
stored in the Working Directory or in a sub-directory of it. After confirming the operation pressing 
the OK button, the Working Directory is created in the Directory path. In the Working Directory a 
file is created with its name equal to the Project Name and the extension ".shp". In order to start 
working with an existing particle system data set, you import your correctly formatted file to the 
project using the File rollout  

File > Import > Data.  

A file selection window allows you to select the data file that you wish to import. After importing 
your data save the project (File > Save Project). Saving the project will include the data in the 
project file, including color and brightness of the particle systems in the data file. In addition, the 
file "shape j3d.dat" will be created, which is an identical copy of your original data file. The file 
shape j3d.dat will be used by the rendering engine of Shape to generate images and spectra.  
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Export data and parameters: 

If you wish to save your particle system data file and/or the parameters of the current project in a 
new file for later use or backup, you open a Save dialog following 

Menu Bar > File > Export > Parameters 

Menu Bar > File > Export > Data 

according to the file that you will save. You then choose the path and file name in the Save dialog 
that opens and confirm the operation with the Save button of the dialog. 

Close a project: 

Menu Bar > File > Close "Project name", 

where "Project name" is the name of the currently open project. 

LOOK AND FEEL 

Every operating environment has a different "Look and Feel" (L&F). Although an interface may 
have the same features and structure, the way in which windows, buttons, tabs, etc. are shown 
on screen depend on the operating environment that you are using. The MCI of Shape is 
optimized for the Windows XP environment. Some people might however, be used to a different 
environment and prefer to change the Look and Feel of the MCI. You can do this by choosing one 
of the items in the selector following: 

Menu Bar > View > Look and Feel  

Macintosh L&F is not available on Windows or Linux systems. It is, however, the default on a 
Macintosh system. 

  

PLUG-INS 

The Plug-in Menu Bar item may contain a selection of modules that operate in windows that are 
separate from the MCI. In Version 1.0 of Shape the only plug-in that is available is the 3D Module 
(see below). Selecting the Shape3D item of the Plug-in rollout opens the 3D Module. This 
selection has the same effect as pressing the 3D Button on the Button Toolbar (see below). 

  

HELP 

The Help item on the Menu Bar gives access to information about Shape. Selecting the item 
Contents opens this User Manual in your default web browser.  

Menu Bar > Help > Contents 
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For quick access to versioning, authoring and copyright information of Shape choose the About 
item of the Help rollout. 

Menu Bar > Help > About 

  

BUTTON TOOL BAR 

 

  

SHAPE Button   

  The SHAPE Button is the large button labeled SHAPE on the left side of the 
Button Toolbar. You press this button to invoke the rendering of images and spectra with the 
Shape Rendering Engine. Doing this produces a series of events. These events include saving 
the current parameters of the MCI, saving the parameters and data from the 3D Module (if open), 
running the Rendering Engine and displaying the results in the MCI. 

News Panel Button 

  The News Panel Button toggles between the News Panel (see above) and the modeling 
panel. 

Convolve Color Images Button 

  Selecting the Convolve Color Images Button tells the Shape Rendering Engine to 
render the convolved color images and spectra. It does also control which images are replayed 
during replay of a sequence using the corresponding features in the Sequence Tab (see 
Sequence Tab below). 

Convolve Grey Scale Images Button 

  Selecting the Convolve Grey Images Button tells the Shape Rendering Engine to render 
the convolved grey-scale images and spectra.  

Model / Observation Button 

  The Model / Observation Button toggles between the display of the convolved color 
image and spectrum and a corresponding observed image. This allows a comparison of 
observation and model by quickly "blinking" between them in the same display. The observed 
image should be in the working directory and have the name "shape.obs.image.jpg" and 
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"shape.obs.spec.jpg" for the image and spectrum, respectively. Note that the centering and 
extension of these images should match those of the parameters used in the displays (or vice-
versa).  

Opaque Star Button 

   The Opaque Star Button allows to render a rotating or expanding opaque star. When 
selected all particles on the far side of the star are set to zero brightness. This allows to simulate 
the spectral information of a rotating star with surface structure. Using a sequence of a rotation of 
the star produces a Doppler-tomogram of 1D Spectra in the corresponding image (see below). 

3D Button 

  Pressing the 3D Button on the Button Toolbar opens the 3D Module. The 3D Button has the 
same function as the Shape3D item in the Plug-in rollout in the Menu Bar.  

  

PARAMETER TABBED PANELS 

Parameter values may either be entered in the corresponding text field using keyboard input or by 
pressing the up or down arrows of the "spinners" located to the right of the text fields. Briefly 
pressing the spinners will change the value by a given amount, which may be different for 
different parameters. Keeping the spinner pressed will continuously increase or decrease the 
number in the text field. Some parameters may also be changed by moving the mouse in the 
corresponding display. 

Image Tabbed Panels 

Image Tab:  

 

Controls the parameters of the window into the World Coordinate System that is seen in 
the image displays. 

X Center, Y Center: The coordinates of the image center in the model world space. Horizontal 
tick- marks show the x-coordinate system. The y-coordinate values can be found using the cursor 
on the PV-diagram. Tick-marks, slit and cursor are only shown, if Show Slit in the Slit Tab is 
selected (see below). 

XY Range: The size of the image from the center to each border. 
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Seeing: The Full-Width Half-Maximum (FWHM) of the gaussian convolution kernel for the 
simulation of the blurring effect ("seeing") of the terrestrial atmosphere on optical images of 
astronomical objects. If the Convolve Images Buttons (see above) are selected, the spatial 
dimensions of the images and spectra are convolved with this kernel. 

Size: The pixel size of the rendered images is 2
Size

. The images are then scaled to the 2
8
 (256) 

pixel size of the displays in the MCI. Reducing the image size results in a faster computing time, 
which may be significant if convolution of the images is performed and resolution is not important, 
e.g. during testing and quick parameters searches. Larger images sizes to result in slower 
performance, but higher resolution. 

Slit Tab: 

 

Controls the position and width of the simulated spectrograph slit in the world coordinate 
system. 

Position: The position of the slit center along the x-coordinate of the world coordinate system. 
The values can either be introduced manually or my positioning and clicking the cursor on the 
image. 

Width: The width of the slit center along the x-coordinate of the world coordinate system. The 
values can either be introduced manually or by scrolling the mouse-wheel if available. 

Show Slit: Choose whether to show the image slit and the scales on the images and pv-
diagrams. Deselecting this check-box is useful to improve performance and visibility while 
replaying image sequences.  

Save Slit: Choose whether to show the image slit on the rendered images that have been saved 
to disk.  

Local Rot and World Rot Tabs 

These tabs control the orientation of the object with respect to the observer in the Local 
and the World Coordinate System. Values given are rotations in Degrees around the 
corresponding axis.  
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x-axis: horizontal increasing towards the right 
y-axis: vertical increasing upwards 
z-axis: perpendicular to the screen, increasing into the screen  

With all the parameters at "0", both coordinate system are identical. However, if the the 
parameters of the rotation in the World System are changed, the whole Local System rotates. 
Changes to the Local System are applied after the World System.  Note that rotations can not be 
performed in arbitrary order.  

Gamma Tab 

 

The Gamma Tab controls the Gamma Correction value applied to the images.  

The Gamma Correction performs the operation pixelvalue^(1/Gamma), where pixelvalue is the 
intensity of the any picture element. Increasing Gamma values enhances the relative brightness 
of low surface brightness features. 

Image Gamma:      Gamma value applied to all image displays 
Spectrum Gamma: Gamma value applied to all spectral displays 

  

Spectral Tabbed Panels 

Controls the parameters of the spatial and radial velocity coordinates that are seen in the 
spectral displays. 

Velocities Tab 

 

Center: The velocity at the center of any P-V diagram. Velocity is horizontal in the P-V diagrams 
Range: The range of velocity from the center of any P-V diagram to the left and right edges 
Resol: The FWHM of the gaussian velocity convolution kernel. This convolution simulates the 
velocity resolution due to natural and instrumental effects.  
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Cur Y: The y-position of the cursor in the p-v diagram in world coordinates. 
Cur Vel: The velocity at the position of the cursor in a display with horizontal velocity axis (P-V 
diagram or 1-D spectral line profile). 

Rainbow CT: Selecting this checkbox will enable the Shape Renderer to apply a Rainbow Color 
Table to the radial velocity color coding in the P-V diagrams, instead of a simple red-blue coding 
which only shows whether a particle is approaching of receding. The rainbow color table allows a 
differentiation of the actual radial velocity. 
 
CT Range: The range of radial velocities around the Center Velocity that will be coded with the 
Rainbow CT. All velocities outside this range will be grey, with values of 0.3 times the original, in 
order not to be outshining the color coded regions. This functions helps to visually extract regions 
of a particular range of radial velocities in the images. 
  

Particles Tab 

These parameters control the size and internal brightness distribution of the particles in 
the raw images. 

 

Size: The radius of a particle in units of the World Coordinate System. 

Type: Currently only one internal brightness distribution is implemented. It is a bright central spot 
with a weaker halo reaching out to the Size from the center of the particle. Note that in the 
convolved images and spectra the internal structure of the particles is erased, since the 
convolution kernel is (should be) larger than the size of a single particle. 

R-Button: Restores the default size for the particles, which is 10 percent of the xy-Range of the 
Image. 

Sequence Tab 

The Sequence Tab controls the calculations of a sequence of images and spectra varying 
one or more parameters of the MCI.  
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The parameters to vary are chosen in the Seq Par Tab (see below). The resulting images are 
written into a sub-directory of the Working Directory. The name of the sub-directory is given in the 
text field at the bottom of the Sequence Tab. Each image of the sequence has the sequence 
name and an image number included in its filename. 

Enable Checkbox: Enables the rendering of an image sequence 

Start Value: This value is added initially to all the parameters that vary in the sequence. The final 
start value is the sum of this value and that shown by the particular parameter text field.  

Num Steps: The sequence will have this number of steps. 

Step Size: The amount by which each parameter will be increased in every step. The value may 
be negative, such the parameter decreases during the sequence. 

Image #: The current image number that was rendered or that is being displayed at playback of 
the sequence. 

Sequence name:  The text field at the bottom of the Sequence Parameter Tab contains the 
name of the sequence. When you start rendering a sub-directory will be created with this name. 
This name and an image number will be included in every image frame that is written in this 
directory. 

Playback control: Press the left and right arrow icons to set the playback direction of the 
sequence. The sequence can be played back either by repeatedly pressing one of the playback 
icons or by pressing any keyboard key. Keeping the keyboard key pressed will automatically 
advance the playback. However, depending on the computing and disc reading speed, playback 
may not be continuous, but jump more than one image. 

  

Seq Par Tab 

In the Seq Par Tab you select which parameters will be varied in a sequence.  

 

One or more variables may be varied simultaneously. The step size of the variation is the same 
for all. The initial value may be different for each of them and is given by the value displayed in 
the text field of the corresponding parameter plus the Start Value in the Sequence Tab (see 
above). 
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IMAGE DISPLAYS 

Spatial projections of the model object and observations are shown in the displays on the 
left hand side of the MCI. Invisible images are accessed by clicking on the corresponding 
tab. 

The image displays by default show the simulated spectrograph slit as a pair of lines. In the 
spectral renderings, only particles which are located within the slit are processed. You change the 
position of the slit using the mouse on the display or by typing the corresponding numbers in the 
Slit Tab. Similarly, the width of the slit is changed by scrolling the mouse wheel or typing the 
numbers in the corresponding text field in the Slit Tab. The horizontal line that connects the 
edges of the slit, indicates the vertical position of the cursor in the P-V diagram on the right to the 
image. This helps to locate corresponding features in the different displays. The plane of the 
image is given by the "x" and "y" coordinates of the World Coordinate System in the horizontal 
and vertical direction, respectively. The "z" coordinate is perpendicular to the image and 
increases into the image. Tick marks at the top of the display show the x-coordinates in the World 
Coordinate System.  

Note: Since the rendering of the images is not a real-time process, once you change the 
Parameters, the images do not correspond to this parameter set until you re-run the rendering 
clicking on the Shape Button in the Tool Bar. 

SPECTRAL DISPLAYS 

Spectral information is shown in the right hand side displays. Invisible spectra are 
accessed by clicking on the corresponding tab. 

The horizontal axis in these images measures the radial Doppler velocity as shown by the scale 
at the top of the display. The vertical axis is the position along the simulated spectrograph slit as 
shown in the image displays on the left. Only in the 1DSpec Tab the vertical axis is not space, but 
the sequence number. A mouse cursor  shows the current y-position and velocity. The elliptic part 
of the cursor is a visual cue for the size and shape of the convolution kernel applied to the 
convolved images. The horizontal width of the ellipse is the same as velocity resolution (Resol) in 
the Velocities Tab. The vertical size of the ellipse corresponds to the Seeing kernel applied to the 
images. For the scale and the cursor to be visible the Show Slit Checkbox in the Slit Tab must be 
checked. 

  

Raw Images and Spectra 

Raw images and spectra show the rendered object unconvolved with seeing or velocity 
resolution kernels.  
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They are shown in the top displays. If the number and size of the particles is not too large, the 
individual particles can be seen in these images.  

  

Convolved Images 

Images in this display have been convolved with a circular gaussian kernel of FWHM equal 
to the Seeing Parameter in the Image Parameters Tab. 

 

Color: Image with color coding according to the colors given to individual sub-objects. You can 
change the colors of the sub-objects from within the 3D Module. The 3D Module opens by 
pressing the 3D Button in the BUTTON TOOL BAR.  
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Obs: Observed image to be used as a reference during modeling. You prepare this image in 
such that the orientation of the spectrograph slit used for acquisition of the P-V diagram on the 
right display  is vertical. The file of the observed image is "shape.obs.image.jpg" and is located in 
the Working Directory.   

Grey: The grey-scale image. Otherwise the same as the color image. No distinction is made 
between sub-objects. 

RB Shift: This image is color coded according to the Doppler-Shift of the particles in the model.  

There are two different modes for the color coding. The red-blue shift (RB-mode) renders a 
particle red when it is red-shifted and blue when it is blue-shifted weighted by their brightness. If 
the Doppler-shift is zero, the color is white. Whenever there is a superposition of red and blue-
shifted particles, the color is a mixture of red and blue, weighted by their corresponding 
brightness.  

The second mode is enabled by selecting the Rainbow CT  Checkbox in the Velocities 
Parameters Tab (see above). It color codes the Doppler-shift in the colors of the visible spectrum, 
from blue to red, with the intensity proportional to the brightness. This color table is applied to the 
velocity range given in the CT Range Parameter to either side of the velocity center set in the 
Center Parameter of the Velocities Parameters Tab. Velocities outside this range are rendered in 
a brightness grey-scale. The Rainbow CT image and the RB-coded image are not available 
simultaneously. In order to obtain the image of the color coding that is not visible, change the 
Rainbow CT Checkbox and press the SHAPE Button to render the model again. 

Chan Map: In this display the channel map is shown. Only particles of the model are included 
that have radial velocities (Doppler-shifts) within the Range Parameter center around the Center 
Parameter in the Velocities Parameters Tab. These are the same particles that are color coded 
with the Rainbow CT feature. 

Convolved P-V diagrams  

Color: P-V diagram with color coding according to the colors given to individual sub-objects. 

Obs: Observed P-V diagram to be used as a reference during modeling. The file of the observed 
image is "shape.obs.spec.jpg" and is located in the Working Directory.   

Grey: The grey-scale P-V diagram. Otherwise the same as the color P-V diagram. No distinction 
is made between sub-objects. 

RB Shift:  
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This image is color coded according to the Doppler-Shift of the particles in the model. For further 
comments see the RB Shift section in the Convolved Images section above. 

1DSpec:  

 

In this tab the 1D spectrum is shown. It is normalized to the height of the display, i.e. the 
maximum peak is always at the top edge of the display. If a sequence was run, the sequence of 
1D-spectra is shown as a color image. Each row of pixels contains the 1D spectrum with the 
intensity coding the value of the spectrum and the color codes the mixture of colors from the 
colors of the sub-objects. Colors that are not actually present in the model indicate a strong 
mixing of the sub-objects in the spectra. If the process that generated the sequence had the 
convolution enabled, then the line spectrum is also convolved. Otherwise, the raw spectrum is 
used. The velocity and the sequence number of a particular 1D Spectrum can be read by pointing 
with the cursor and reading the numbers in the status bar (see below). 
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Status Bar 

 

The status bar at the bottom of the MCI provides information about the current cursor position on 
the images in World Coordinates and velocity (x, y) as well as pixel coordinates of the 
corresponding image (pX, pY). On the right side of the status bar the filename of the Current 
Image is given at which the cursor is pointing.  
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THE 3D MODULE 

The 3D Module has the function to control some properties of an object and its sub-sections. 
Among others, these properties include their position, size, orientation, color, brightness and, very 
importantly, their velocity structure. In this module, objects can be changed in their shape, like 
stretching them in a particular direction. For complex structural manipulation it is recommended to 
employ an external 3D modeling software and them import the data in a suitable format into 
Shape. 

 

 

General strategy for the usage of the 3D module 

Any imported dataset is visible in the 3D module, situated in the World with its associated World 
Coordinate System. The data may either be in the form of a Particle System (PS) imported from 
the shape j3d.dat file or e.g. in the form of the Virtual Reality Markup Language (VRML) format. 
Some simple primitives like spheres and tori can be created directly from the 3D Module. These 
primitives can be combined or deformed to yield disks, ellipsoids or other more complex 
structures. Any non-particle system objects (also called nodes) must then be converted to a 
particle system. After that you assign color, brightness and velocities. Orientation and any other 
transformations can either be applied before or after converting the node into a PS. Now you can 
render the complete object in the Main Control Interface (MCI). 

WARNING: It is very much recommended to premeditate every operation that you will 
perform to an object. At this time there is NO GENERAL UNDO function available. All 
backward changes have to be done manually at this stage.
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Menu Bar 

 

File 

Menu Bar > File > New 

In order to start a new object from an empty World you select New. This will erase all previously 
existing sub-objects. WARNING: At this time this operation can not be undone directly and 
completely. There are three ways of recovering some or all of the information. If you have saved 
the World in this File Menu then you can open it again selecting Menu Bar > File > Open. 
Secondly, you can use the File > Import > Data in the MCI to reload the particle system data that 
have been saved when you last rendered the object. Third, you can reload the project from the 
MCI using Menu Bar > File > Open Recent Project. 

Menu Bar > File > Open 

Menu Bar > File > Save 

Menu Bar > File > Import > VRML 

Import a VRML object file. This will add the objects contained in the VRML file to the current 
World. 

Menu Bar > File > Export > VRML 

Export any VRML objects in the scene. VRML objects which have been converted to Particle 
Systems can not be exported in VRML format. 

Menu Bar > File > Exit 

Exit the 3D module. 

Groups 

Create and Remove Group 

Create joins all selected sub-objects into a single group. Transformations like moving and scaling 
are performed to all sub-objects in the group simultaneously. Remove opens a group and 
separates sub-objects from a group. 

Create and Remove Particles System 

Creates a Particle System from the selected VRML objects. Destroys and removes the object 
from the world. 

View 

Select which sections of the Tool Bar are displayed. The available tools are Primitives, 
Transforms, Camera and Node Information (see below). The Primitives, Transforms and 
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Camera tool bar buttons are located above the View Panel where the objects are shown from 
different Camera directions. The Node Information Panel is located to the right of the View Panel.  

Help 

Opens this document. 

  

Tool Bars 

 

Primitives 

   

Buttons to create new sub-objects in the form of simple geometric shapes (primitives). The 
currently available primitives are Sphere, Cone and Torus.  

To create a new primitive select the desired button and press the mouse in any of the View 
Panels (see below). Keep the mouse pressed and drag to the right and up to increase the width 
and height, respectively. 

Transforms 

 

Use this tool bar to Move, Scale and Rotate objects.  

To apply any transform, you first select the object. Selection of an object can be achieved by 
either activating the Select Button and then clicking on some part of the object or by clicking on 
the object in the Node List of the Node Information Panel. To actually perform the Transform you 
activate the corresponding Transform Button (Move, Scale or Rotate) and finally move the 
object by dragging the mouse or introducing the transform values in the Coordinates Panel of the 
Node Information Panel.  

To restrict a transform along a particular axis drag the mouse while pressing the x, y or z key of 
your keyboard. Choose the Coordinate System in which to perform the transform by selecting one 
of the radio buttons (World, Local) in the Rotation Panel (Node Information Panel > Coordinates > 
Rotation). 

Camera  

 

The Camera Tool Bar allows you to Zoom or Pan  the viewpoint in all the View Panels. The 
Perspective Panel does also allow to Rotate the viewpoint around the origin of the World 
Coordinate System. 
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View Panels 

The View Panels show the World from 
different directions, Top, Front, Left, 
Perspective and Shape view. The Top view 
looks along the y-axis, the Front view along 
the z-axis and the Left view is a projection of 
the World along the x-axis. At start-up the 
Perspective view looks along the z-axis and 
is the same as the Front view. In the Shape 
view the observer looks at the same scene 
as in the images in the MCI. It communicates 
directly with the values in the Image 
Parameters Tab.   

Right-clicking with the cursor on the frame of 
a view panel opens a menu from which you 
can choose a different viewing direction. In 
some viewing directions, it does also allow to 
quickly adjust the size of the view panel to 
the size of the model objects. Right-clicking 
and dragging on the view panel directly 
invokes panning, i.e. moving the camera.  
Using the mouse wheel on the view panel 
allows to interactively zoom in or out. 

Shape view: This view panel gives a 
preview for the rendered image of the MCI. 
It can be used to adjust the viewing 
direction applying the Camera 
Transformations of the Tool Bar. The 
values of the Image Parameter Tab are 
reproduced in the Shape Camera Panel of 
the Nodes Panel. They can be changed 
either in the MCI or in the Shape View 
Panel.  
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Nodes Panel 

In the Nodes Panel you manage the model 
objects and it's parts. It is located to the right 
of the View Panels. There are four collapsible 
main panels: the Node Attributes, 
Coordinates, Node List and Particle Systems.  

Node Attributes 

The Node Attributes include the Name, 
Type, Polygon type and Color.   

Name: displays the name of the node. It can 
be changed in the corresponding text field.  

Type: shows whether the node is a Particle 
System or a Polygon Surface.  

Polygon: select how a polygon surface is to be displayed, as points, wire frame or a shaded 
surface. This selection has no effect on Particle Systems, including surface objects which have 
been converted to Particle Systems. 

Color: The color swatch shows  the current color of the node. You can change the color by 
clicking on this swatch. The color chooser will open and allow you to set the color. 

Coordinates 

The Coordinates Panel holds the information on the 
Position, Rotation (orientation) and Scaling of the nodes. 

Position 

The Position Panel displays the x,y and z coordinates in 
the World Coordinate System. The values may be 
changed directly in the corresponding text fields. This 
allows precise placement of each node.  

x, y, z: The World Coordinates of the Node. 

Show Gizmo: A checkbox to show or hide the axes 
(gizmo ) of the local coordinate system associated with 
the Node. 

Scale: The scaling of the Gizmo. 

Rotation 

The Rotation determines the orientation of the object with 
respect to the various Coordinate Systems and hence with 
respect to the observer. The Rotation can be changed 
with respect to two Coordinate Systems, the World 
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System and the Local System. Rotation about the axes of the Local System is important e.g. to 
rotate the object around some symmetry axis.   

x, y, z 

There are two rows of values for rotations. The top row  indicates the rotation around the 
respective axes in the World Coordinate System while the bottom row shows the rotation in the 
Local Coordinate System. Which one of them is the active system is determined by the selection 
of the radio buttons below with the exclusive options of World or Local Axes. 

Scale 

You change the size of an object or sub-object by Scaling it. The scaling is performed in the local 
Coordinate System.  

x, y, z 

The values of the scaling of the objects or sub-objects that have been applied after they have 
been created or imported. The values indicate the scaling along each of the axes of the Local 
Coordinate System. 

 

 

Node List 

The Node List shows the names and some of the 
attributes of the node. The Remove Button allows 
a node to be deleted. Before finally deletion of a 
node a confirmation dialog is opened. Note that 
after confirmation this operation can not be 
undone. 
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Particle Systems 

In the Particle System Panel you manage the some 
properties of the Particle System that you have 
imported or created in the 3D Module. One 
important function of the Particle System Panel is to 
set the velocities that the Particles will have. For 
Particle Systems that have been imported as such 
these velocities may already be included. However, 
with these may be overridden using the parametric 
velocity field applied here. The parametric velocities 
will be applied only if the Calculate Velocities 
Checkbox is set. 

Properties 

The Properties Sub-Panel shows the Brightness, 
Flux, Color, Number of Particles and the Velocity 
Parameters. 

Brightness 

The Brightness is a relative measure of the 
brightness of an individual Particle. Its function in the 
model is that of the emissivity in a gaseous nebula. 

Flux 

The Flux is the total emission coming from this 
Particle System. It is the product of the Brightness 
and the Number of Particles (# Particles). 

Color 

The color of the Particle System. 

# Particles 

The number of Particles in the Particle System. 

Calculate Velocity 

Check this tick box if you wish that the velocities of the Particles are to be calculated as a function 
of the position vector of the Particle in the World Coordinate System. If this tick box is unchecked 
the velocities are either zero (for Particle System created in the 3D Module) or they are the 
velocities that have been imported with the external Particle System.  

There are three different types of velocity field from which you can choose using the drop-down 
list: RADIAL EXPANSION, DISK ROTATION and SOLID BODY ROTATION. 
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RADIAL EXPANSION 

The velocity vector is always directed along the position vector in the local coordinate 

system and obeys the following formula: 

 

where A, B, C and D are the coefficients. p is the particle distance from the origin of the local 
coordinate system (length of the position vector)  and r is a reference distance.  

Using suitable combinations of these coefficients, a large variety of velocity fields can be 
generated. Some particularly important examples are the following: 

Constant radial velocity: 

A = velocity 

B = C = D = 0 

"Hubble type" flow (i.e. velocity vector is proportional to the position vector): 

A = C = D = 0 

B = velocity at reference distance r 

If you are unfamiliar with power-law functions, you might want to use an external 

plotting program to plot the velocity and adjust the coefficients before introducing them 

in Shape. 

DISK ROTATION 

The velocity vector is always perpendicular to the position vector and the z-direction of 

the local coordinate system. It obeys the following formula: 

 

where A, B, C and D are the coefficients. p is the particle distance from the origin of the local 

coordinate system (length of the position vector)  and r is a reference distance . is the unit 
position vector of the particle in the xy-plane of the local coordinate system. Note that the rotation 
axis of the rotator is restricted to the z-axis of the local coordinate system. 

Using suitable combinations of these coefficients, a large variety of velocity fields can be 
generated. Some particularly important examples are the following: 
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Keplerian disk: 

A = B =  0 

D = velocity at the reference distance r 

D = - 0.5 

If you are unfamiliar with power-law functions, you might want to use an external 

plotting program to plot the velocity and adjust the coefficients before introducing them 

in Shape. 

SOLID BODY ROTATION 

The velocity vector is always perpendicular to the position vector and the z-direction of 

the local coordinate system.  

For the solid body rotation only coefficient A is used and it corresponds to the velocity at the 
reference distance r. Note that the rotation axis of the rotator is restricted to the z-axis of the local 
coordinate system. 
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TUTORIALS 

How to make channel maps 

A channel map is an image which includes only those regions of a nebula which have a 

radial velocity (Doppler-shift) within a given range. If the range of velocities in a channel 

map is small compared to the whole range of velocities that are present in the nebula, 

these maps allow to "dissect" the nebula along the line of sight. However, similar to the 

case of position-velocity diagrams this is only a good view of the spatial dimension, if 

there is a reasonably regular relation between the spatial and the velocity domain. 

However, even if there is no such relation, the channel map still conveys important 

information on the structure and kinematics of the object. 

To produce a channel map centered at a velocity of -5 and a range of 0.3 on both sides of 

the velocity center, follow these steps: 

1. In the Velocities Parameter Tab set the Center to -5 and the Range to 0.3. 

2. It is convenient to enable the Rainbow CT and set the CT Range to the same as the 

velocity Range, i.e. 0.3. This allows to visualize the channel map not only in the Chan 

Map image, but also in the RB Shift image. The Rainbow CT will mark the regions 

selected by the channel map in the grey-scale version of the full image. In some models 

this allows a clearer insight in the location of the selected region within the whole object. 

 

3. Choose any other parameter according to you needs. 
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4. If you wish to produce a sequence of channel maps stepping through the full range of 

the object, do the following in addition to the previous steps: 

- Select the Enable Checkbox in the Sequence Parameter Tab.  

- Set the Center value to the initial velocity of the sequence (typically the same as the 

highest blue-shift that is present in the object, which can be read from the pv-diagram 

using the cursor). 

-  In the Sequence Parameter Tab set the Start Frame = 0 

-  Set the Step Size to the difference between the Center velocities of adjacent velocity 

channels. 

-  The Num Steps parameter should be the difference between the highest and lowest 

radial velocities divided by the Step Size. 

- Set the Image # to 0. 

- Type a suitable Sequence Name in the text field at the bottom of the Sequence 

Parameter Tab. The results of this sequence will be written into a sub-directory with the 

same name. From these image sequences, animations can be assembled using external 

movie editing programs. For a simple playback of the sequence, choose the playback 

direction and press any keyboard key or repeatedly click on the playback button in the 

Sequence Parameter Tab.  
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Particle system templates 

In this tutorial you will learn how to use Shape starting with a particle system template that you 
download from the ShapeSite. 

You go to the Templates area of the ShapeSite using your favorite Internet browser and 
download to your working directory the particle system template you wish to use. If compressed 
and packed, unpack the downloaded file. A sub-directory is created with several files, which at 
least contain the files "shape j3d.dat", "shape j3d.inp" and an info file with the extension ".txt", 
which contains some information on the object model and how to use the template. Some 
template packages may contain the original model files from the external 3D modeling software. 
This allows you to modify the template data as needed. Some changes can be done directly in 
the 3D Module of Shape. The information in the info file may be as follows: 

1. Download and unpack the zip-file in a directory of your choice 

2. Start Shape 

3. Start a new Project: 

File > New Project 

Insert a project name and path. 

4. Import the particle system data: 

File > Import > Data 

With the Open Dialog navigate to the directory where you unpacked the template. Select 

the file shape j3d.dat. Verify that the data have been imported correctly. Open the 3D 

Interface using the 3D button on the tool bar. If the particle system is visible, the data 

have been imported properly. 

5. Import the project parameters: 

File > Import > Parameters 

With the Open Dialog navigate to the directory where you unpacked the template. Select 

the file shape j3d.inp. The parameters on the Parameter Tabs should have changed. To 

verify, run Shape by clicking on the Shape Button on the Tool Bar. The rendering dialog 

should open and after finishing the render the image panels should show the rendered 

image and spectral information. 

6. You can now manipulate the observing parameters for the object in the Parameters 

Tabs and/or manipulate the data using the 3D Module. 
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7. If you wish to modify the original data, you may use 3DStudio Max to open and 

modify the file bipolar sym 1.max. To export the result to shape j3d.dat use the export 

script Sh out j3d.ms.  

 

External VRML and .obj 3D model files 

The Virtual Reality Markup Language (VRML) format is a common scene description format. It 
can be used to import objects created in external 3D modeling software into Shape via the 3D 
Module. Note that velocity information is not included in the VRML format at must be generated 
with the 3D Module options that are available for this purpose. Let us assume that you already 
have a file with your object in the VRML format called "object.wrl" (wrl is the typical file extension 
for VRML files). To import the file go to the menu bar of the 3D Module. Choose 

File > Import > VRML 

Now a file selection dialog opens. Go to the directory in which your "object.wrl" file is located and 
select the file. Confirm the selection by clicking on the Open button of the dialog. Your object 
should now be visible in the viewports of the 3D Module as a shaded surface. In order to be 
renderable in Shape, this surface object must be converted into a particle system. To do this 
select the object node in the Node List and then go to the menu bar of the 3D Module and choose 

Groups > Create particle system 

The shaded surface has now turned into a collection of points, one at each vertex of the original 
surface object. You may now change the color and velocity structure of the particle system in the 
corresponding panels on the right of the 3D Module. You can also apply any of the 
Transformations available on the Tool Bar. Now you can render the object choosing suitable 
parameters in the MCI and by clicking on the Shape Button. 

A similar procedure can be followed to import .obj files. 

 

Particle systems from external 3D modeling software 

Modeling with Shape is most detailed harnessing the powerful particle systems that come with 
some external 3D modeling suites. ParticleFlow in 3DStudio Max or similar systems in other 
modeling suites can be controlled in detail either interactively or, most precisely, via script 
programming. A script for exporting ParticleFlow data in the Shape particle data format (see 
below) is provided in the download area of the ShapeSite. Check the corresponding download 
area for export scripts for other 3D modeling packages. 

Once you have exported your particle data file, it can be imported into Shape. This is done via the 
Menu Bar in the MCI. From the Menu Bar choose 

File > Import > Data  

Now the file selection dialog opens. Select and confirm the import of the file. If the 3D Module is 
open, the particle system should be visible in the viewports and the Nodes Panel. It can now be 
further processed (changing color, brightness, particle distribution, velocity field, etc.) in the 3D 
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Panel or directly rendered with the Shape Button of the MCI. Before the data are rendered, they 
are written to the shape j3d.dat file, which is read by the renderer. If you save the project, the 
imported data are saved with the project.  

 

Model templates 

See the latest instructions on the News Panel at startup of Shape. 
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FILE FORMATS 

The ASCII data formats of the particle system data and parameter files "shape j3d.dat" and 
"shape j3d.inp" are described. This allows users to write export scripts or programs for external 
modeling software. An example script for 3DStudio Max which produces the file "shape j3d.dat" 
from selected particle systems of type Particle Flow can be downloaded from the 3DStudio Max 
section of the link "External 3D modelers" on the ShapeSite. The file "shape j3d.inp" controls the 
parameters of the Parameter Tabs of the MCI. The file "shape j3d.inp" is written by the MCI when 
you render the object by clicking on the Shape Button. The data from both files are included in the 
project file when you save the project. Generally there is no need to externally modify the 
parameter file "shape j3d.inp". It's content in directly controlled via the Parameters Tab. However, 
note that the parameters are written to file only when you render or save the project. 

Note: These file formats are subject to change with mayor new releases of Shape. 
Secondary releases will conserve these formats. 

General format of the file "shape j3d.dat": 

- Main header  
- First particle system header  
- Particle data of first particle system  
- Headers and particle data of any further particle systems 

Details of file format (example):  

Lines starting with "#" denote comments and are not read by the rendering engine. The two 
particle systems in the data file contain two particles each. The number of particle systems or 
particles per system is not restricted a priory. However, the rendering time is roughly proportional 
to the number of particles in the system.  

# Multi-object particle positions for SHAPE  
# Number of Systems:  
2  
# TIME:  
0.  
# Particle System ID:  
PF Source 01  
# Position of PS in World Coord:  
0.0 0.0 0.0  
# Color of PSystem (RGB Alpha)  
0 255 153 255  
# Number of Particles:  
2 
# N Part X Y Z VX VY VZ SIZE AGE AX AY AZ  
1 1.10329 67.0187 -57.5515 0.158115 9.60459 -8.24782 1.0 5.0 0.0 0.0 0.0  
2 -51.5906 18.4107 -42.7453 -7.39355 2.63847 -6.12592 1.0 5.0 0.0 0.0 0.0                               
# Particle System ID:  
PF Source 02  
# Position of PS in World Coord:  
0.0 0.0 0.0  
# Color of PSystem (RGB Alpha)  
0 225 53 255  
# Number of Particles:  
2 
# N Part X Y Z VX VY VZ SIZE AGE AX AY AZ  
1 1.10329 67.0187 -57.5515 0.158115 9.60459 -8.24782 1.0 5.0 0.0 0.0 0.0  
2 -51.5906 18.4107 -42.7453 -7.39355 2.63847 -6.12592 1.0 5.0 0.0 0.0 0.0  
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The detailed format of the "shape j3d.inp" file is as follows: 

Project name 
#Check boxes: Conv Grey, Conv Color, VelShift, Logscale, Verbose, Show Slit, Vel Slice, Opaque Star 
true true false false false false false false 
#ImCenterX ImRangeX 
0.0 300.0 
#ImCenterY ImRangeY 
0.0 300.0 
#VelCenter VelRange ColorTabRange 
0.0 500.0 50.0 true 
#Seeing VelResol 
20.0 25.0 
#gammaim gammaspec 
1.5 2.5 
#ImSizeSp.value 
8 
#SlitPosCenter SlitWidth SlitIntense 
0.0 39.375 1.0 
false false 
#WorldRotX WorldRotY WorldRotZ 
20.0 0.0 0.0 
false false false 
#LocalRotX LocalRotY LocalRotZ 
0.0 0.0 0.0 
false false false 
#ParticleRadius PSType  
20.0 1.0 
#Do Sequence? Step Num Steps  
false 0 1 0.0 

 

Known issues and bugs 

- If using a multi-monitor system, currently you can not change the viewpoint of a view panel while 
the 3D Module is displayed on a secondary monitor. The work around is to move the 3D Module 
to the main monitor and do the change there. Now you can move the 3D Module back and the 
new view will work. 

- The Shape View Panel does not Zoom Extent on selecting the corresponding option from the 
right-click pop-up list. 

 

Some external 3D Modeling Systems 

This is only a small selection of commercial and free 3D modeling system around. Please feel 
free to find the one you like most. However, please note that in order to work with Shape the 
system needs at least capability to export to VRML format. It is highly desirable to have a good 
Particle System tool in combination with a scripting language that allows you to export particle 
positions and velocities in the format that Shape can read. 
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3DStudio Max - Data export script (MaxScript) for Shape is available at the ShapeSite. 3D Studio 
Max is a commercial 3D modeling suite. The Particle Flow system has been used extensively for 
modeling with Shape. Surface structures can be exported in VRML format, which can be imported 
into Shape and then converted into a Particle System. 

Blender - Free 3D modeling suite that is included in some Linux distributions. Scripting language 
is Python. Currently there is no Particle System export script available (please write one and 
share it with the Shape user community). 

Maya - Commercial 3D modeling suite. Free educational version is available with limited 
capabilities. However, these are not very restrictive and very well suited for usage with Shape. 
There is currently no export script (MelScript) available for Particle Systems (please write one and 
share it with the Shape user community). 
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